Downloading Older Versions of Plugins

Can I Download Older Versions of Plugins?

When pushing updates or new features to an older plugin, the product will then require the latest versions of FCPX and or MacOS when redownloading. This is because new updates to the plugin are to address either bugs and or to add new features to a plugin that will often take advantage of new features within FCPX.

If you are looking to download a plugin pre-update that is compatible with an older version of FCPX or MacOS, we currently do not offer this ability. This is because older versions of plugins are no longer supported by our development team and were often updated to fix known bugs within them.

We recommend keeping a copy of your plugin installer on an external drive or somewhere on your main drive if you wish to always have access that version of the plugin.